Give access is not working on US region

Incident Report for Entitle Status Page

Postmortem

22 January 2026 - Post-Incident Report: Delayed Permission Provisioning in US Region

Incident Date: 22 January 2026
Affected Region: US
Status: Resolved
Timezone: UTC

Summary

On 22 January 2026, around 18:00 UTC some customers experienced delays in permission provisioning. At 20:00 UTC we validated the the issue is related to US region only.

The underlying issue was resolved at approximately 20:30 UTC, restoring normal service.
The incident remained open until approximately 22:00 UTC to allow time to validate recovery and collect confirmation from all affected customers.

Impact

  • A limited number of customers experienced delays in permission grants
  • Permission requests were processed later than expected
  • No data loss occurred
  • No incorrect permissions were granted
  • No security impact was identified

Root Cause

The issue was caused by a temporary backlog in background job processing in the US region, which delayed execution of permission requests.

Resolution

Our engineering teams mitigated the issue by:

  • Releasing delayed background jobs
  • Scaling processing capacity to clear the backlog
  • Verifying successful permission grants

Service functionality was restored around 20:30 UTC.

Validation & Closure

Following service restoration, we:

  • Actively monitored the system for stability
  • Confirmed successful processing with affected customers

After completing validation with customers impacted by this issue, the incident was formally closed around 22:00 UTC.

Prevention

To reduce the likelihood of similar incidents, we have:

  • Improved monitoring and alerting for delayed background processing
  • Enhanced visibility into regional job execution health
  • Updated system configurations to prevent queue backlogs

Closing

We apologize for the inconvenience and appreciate your patience.
If you have any further questions or experience related issues, please contact BeyondTrust support team by https://www.beyondtrust.com/customer-support-guide.

Posted Jan 26, 2026 - 18:46 UTC

Resolved

This incident has been resolved.
Posted Jan 22, 2026 - 22:11 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 22, 2026 - 20:32 UTC

Identified

The issue has been identified in one of our backend services ( pub sub module) and a fix is being implemented.
Posted Jan 22, 2026 - 20:32 UTC

Investigating

We are currently investigating this issue.
Posted Jan 22, 2026 - 20:18 UTC
This incident affected: Access Change Requests.